7
11
2015
0

POJ1417:True Liars

                   True Liars
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2314   Accepted: 719

Description

After having drifted about in a small boat for a couple of days, Akira Crusoe Maeda was finally cast ashore on a foggy island. Though he was exhausted and despaired, he was still fortunate to remember a legend of the foggy island, which he had heard from patriarchs in his childhood. This must be the island in the legend. In the legend, two tribes have inhabited the island, one is divine and the other is devilish, once members of the divine tribe bless you, your future is bright and promising, and your soul will eventually go to Heaven, in contrast, once members of the devilish tribe curse you, your future is bleak and hopeless, and your soul will eventually fall down to Hell.

In order to prevent the worst-case scenario, Akira should distinguish the devilish from the divine. But how? They looked exactly alike and he could not distinguish one from the other solely by their appearances. He still had his last hope, however. The members of the divine tribe are truth-tellers, that is, they always tell the truth and those of the devilish tribe are liars, that is, they always tell a lie.

He asked some of them whether or not some are divine. They knew one another very much and always responded to him "faithfully" according to their individual natures (i.e., they always tell the truth or always a lie). He did not dare to ask any other forms of questions, since the legend says that a devilish member would curse a person forever when he did not like the question. He had another piece of useful informationf the legend tells the populations of both tribes. These numbers in the legend are trustworthy since everyone living on this island is immortal and none have ever been born at least these millennia.

You are a good computer programmer and so requested to help Akira by writing a program that classifies the inhabitants according to their answers to his inquiries. 

Input

The input consists of multiple data sets, each in the following format :

n p1 p2
xl yl a1
x2 y2 a2
...
xi yi ai
...
xn yn an

The first line has three non-negative integers n, p1, and p2. n is the number of questions Akira asked. pl and p2 are the populations of the divine and devilish tribes, respectively, in the legend. Each of the following n lines has two integers xi, yi and one word ai. xi and yi are the identification numbers of inhabitants, each of which is between 1 and p1 + p2, inclusive. ai is either yes, if the inhabitant xi said that the inhabitant yi was a member of the divine tribe, or no, otherwise. Note that xi and yi can be the same number since "are you a member of the divine tribe?" is a valid question. Note also that two lines may have the same x's and y's since Akira was very upset and might have asked the same question to the same one more than once.

You may assume that n is less than 1000 and that p1 and p2 are less than 300. A line with three zeros, i.e., 0 0 0, represents the end of the input. You can assume that each data set is consistent and no contradictory answers are included.
 

Output

For each data set, if it includes sufficient information to classify all the inhabitants, print the identification numbers of all the divine ones in ascending order, one in a line. In addition, following the output numbers, print end in a line. Otherwise, i.e., if a given data set does not include sufficient information to identify all the divine members, print no in a line.

Sample Input

2 1 1
1 2 no
2 1 no
3 2 1
1 1 yes
2 2 yes
3 3 yes
2 2 1
1 2 yes
2 3 no
5 4 3
1 2 yes
1 3 no
4 5 yes
5 6 yes
6 7 no
0 0 0

Sample Output

no
no
1
2
end
3
4
5
6
end

Source

   这道题就算是并查集学(预习)的收尾吧,应该也是我这几天做的最艰难的一道并查集了吧。。。

   首先我们可以用并查集维护一个联通块里的关系,通过分析可以知道如果一个人说另一个人是说真话的人,那么这两个人是同类人,否则这两人就是不同类的人,我们可以用一个dis数组存他与其父亲的关系,dis==0则两人是同类人dis==1则两人是不同的人,路径压缩可以xor什么的乱搞一下。

   然后剩下的问题要用dp做,先把在同一个集合里的人缩成一个node,node.s和node.d记录和这个集合根相同和不同的人的数量,然后做dp。

   dp[i][j] = max(dp[i-1][j-node[i].s]+node[i].s,dp[i-1][j-node[i].d]+node[i].d);

dp[i][j]表示前i个集合中最多j个人中说真话的人的个数最多是多少。(有一个细节是转移时要注意前一个状态是否可以达到)。

   输出是的细节我说不太清楚,具体看代码吧。。

   细节:调的时候一堆一堆的细节。。果真是我太弱了。。下标都会打错。。

#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 610
using namespace std;
struct data{int s,d,c;} node[N];
int mp[N],di[N],sa[N],f[N],dis[N],dp[N][N];
int n,p1,p2,F,F1,F2,a,b,t,a1,a2,s,tmp;
char opt[5];
int get(int x){
    int t;
    if(x!=f[x]) {t = f[x];f[x]=get(f[x]);dis[x]^=dis[t];}
    return f[x];
}
int main(){
	while (1){
		scanf("%d%d%d",&n,&p1,&p2);
		if (!n && !p1 && !p2) return 0;
		int F = 1;
		if (p1==p2) F = 0;
		for (int i=0;i<N;i++) f[i] = i;
		memset(sa,0,sizeof(sa));
		memset(di,0,sizeof(di));
		memset(mp,0,sizeof(mp));
		memset(dis,0,sizeof(dis));
		memset(dp,0,sizeof(dp));
		memset(node,0,sizeof(node));
		for (int i=0;i<n;i++){
			scanf("%d %d %s",&a,&b,&opt);
			int v = opt[0]=='y'?0:1;
			int x = get(a),y = get(b);
			if (x!=y){
				if (x<y){f[y] = x;dis[y] = dis[a]^dis[b]^v;}
				else {f[x] = y;dis[x] = dis[a]^dis[b]^v;}
			}
		}
		if (!F){printf("no\n");continue;}
		for (int i=1;i<=p1+p2;i++)
			t = get(i),(dis[i]==0)?sa[t]++:di[t]++;
		s = 0;
		for (int i=1;i<=p1+p2;i++)
			if (sa[i]>0){mp[i] = s;node[s].s = sa[i];node[s++].d = di[i];}
		a1 = min(node[0].d,node[0].s);a2 = max(node[0].d,node[0].s);
		if (a1==a2) {printf("no\n");continue;}
		for (int i=a1;i<a2;i++) dp[0][i] = a1;
		for (int i=a2;i<=p1;i++) dp[0][i] = a2;
		for (int i=1;i<s && F;i++){
			a1 = min(node[i].s, node[i].d);a2 = max(node[i].s,node[i].d);
			if (a1==a2) {F = 0;break;}
			for (int j=a1;j<=p1;j++){
				dp[i][j] = dp[i-1][j-a1]?(dp[i-1][j-a1]+a1):0;
				if (j-a2>0 && dp[i-1][j-a2]){
					t = dp[i-1][j-a2]+a2;
					if (t>dp[i][j]) dp[i][j] = t;
				}
			}
		}
		if (dp[s-1][p1]!=p1) F = 0;
		t = p1;
		for (int i=s-1;i && F;i--){
			F1 = F2 = 0;
			if (t>node[i].s && dp[i][t]-node[i].s==dp[i-1][t-node[i].s]) F1 = 1;
			if (t>node[i].d && dp[i][t]-node[i].d==dp[i-1][t-node[i].d]) F2 = 1;
			if (F1 && F2) F = 0;
			if (F1) {node[i].c = 0;t-=node[i].s;}
			else {node[i].c = 1;t-=node[i].d;}
		}
		if (t==node[0].s) node[0].c = 0;
		else node[0].c = 1;
		if (F==0) {printf("no\n");continue;}
		for (int i=1;i<=(p1+p2);i++)
			if (node[mp[f[i]]].c==dis[i]) printf("%d\n",i);
		printf("end\n");
	}
}
Category: POJ | Tags: | Read Count: 463

登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter

Host by is-Programmer.com | Power by Chito 1.3.3 beta | Theme: Aeros 2.0 by TheBuckmaker.com