7
9
2015
0

POJ1456:Supermarket

                        Supermarket
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9914   Accepted: 4296

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.


Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.
 
 
    同样是并查集这题就比食物链良心多了、、、
    这题可以用贪心+并查集优化过,先对n件物品按照价值排序,然后从大到小的对于每件物品判断是否可以在规定时间内出售,即在规定时间之前是否有空余时间。我们可以用并查集维护每一个时间点之前最近的为空的时间,这种思路以前的模拟赛里也类似的出现过,然后这题就可以完美的解决了
 
 
 
#include <cstdio>
#include <algorithm>
#define N 100000
using namespace std;
int f[N+10],n,ans;
struct data{int val,pos;} a[10010];
bool cmp(data a,data b){return a.val>b.val;}
int get(int x){return f[x]==x?x:f[x] = get(f[x]);}
int main(){
	while (~scanf("%d",&n)){
		ans = 0;
		for (int i=1;i<=n;i++) scanf("%d%d",&a[i].val,&a[i].pos);
		sort(a+1,a+1+n,cmp);
		for (int i=1;i<=N;i++) f[i] = i;
		for (int i=1;i<=n;i++){
			int p = get(a[i].pos);
			if (p>0){
				f[p] = f[p-1];
				ans+=a[i].val;
			}
		}
		printf("%d\n",ans);
	}
}

 

Category: POJ | Tags: | Read Count: 342

登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter

Host by is-Programmer.com | Power by Chito 1.3.3 beta | Theme: Aeros 2.0 by TheBuckmaker.com